You must be logged in to post messages.
Please login or register

Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.3 replies
Rise of Legends Heaven » Forums » Tech Support » LAN Connection Error
Bottom
Topic Subject:LAN Connection Error
Bob The Violent
Zekeling
posted 09-25-08 00:56 AM EDT (US)         
Wanted to see if anyone else out there still has this issue or if it has ever been resolved. I saw several archived threads all unsolved, and no recent activity.

The scenario is that all LAN games will start just fine and let you play for about 30 seconds and then get the following error and end for all players. I have tried all the typical debugging techniques. Driver updates, Windows updates, firewall on/off, with router/direct cabling, game video or audio settings on/off, unpatched game/ latest patch/even reinstalled the game too! A few friends even tried a full format+reinstall of windows and ROL.

All yield the exact same error message which ends the game for all players.

"Connection Error - 20 Seconds"
"You have lost your connection to [Player name]. No data has been received from [Player name] in over 20 seconds. Please decide how to procede."


(The odd thing is that even though it says it did not receive data in "over 20 seconds" during that time you can chat back and forth and move units around and watch your allies build. So the network connection IS in fact working and so the actual problem must be something else.)
AuthorReplies:
PCDania
Zekeling
(id: PCD)
posted 09-25-08 03:36 AM EDT (US)     1 / 3       
Unfortunately I haven't heard or seen anything that works 100%. Regardless if Windows Firewall is disabled or not, try make sure the ports noted in below article are all open for RoL in Windows Firewall (remember the ports hidden in the text right over the list). I can't guarantee it works but it's worth a shot:

http://support.microsoft.com/kb/917714

Personally I believe it's a bug in the network part of the game triggering that message. I believe so as there also sometimes is strange behaviour of the network part of the game when logging on and when updating the game.

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.

[This message has been edited by PCDania (edited 09-25-2008 @ 03:37 AM).]

Bob The Violent
Zekeling
posted 09-25-08 05:17 PM EDT (US)     2 / 3       
Thank you for the reply.

Router was my #1 suspect when I first had weird connection issues, but the puzzling thing with all of this is that the game worked 100% perfect for the first 2 weeks. I played games online and on LAN multiple times! Then one day they both just went defunct for multiplayer. As far as I can tell nothing changed on my end.

I'll go back and retry bypassing the router entirely AND/OR doing a direct connection to another computer through a switch as a test.

One more thing I didn't mention. Just after this problem started, maybe a day or two later, I was no longer able to log in online. The day the LAN disconnect issue started I could still get online, but a few days later it went out too.

I would agree with you, that it is probably a bug in the network code which unfortunately will most likely never be patched since I heard BHG discontinued support.

So can you and other people play on LAN and get online right now? Me and several friends (on different computers, different ISPs, and in another city even.) are all having this same issue and I'm curious as to why it is just us, or if other people have this too.
PCDania
Zekeling
(id: PCD)
posted 09-25-08 07:18 PM EDT (US)     3 / 3       
Strange, when clicking my username for logging onto the multiplayer server I get a CTD now, never experienced that before. Maybe the game doesn't like my new CPU...

I have no means of trying to play a local LAN game as I don't know anyone here who owns RoL and would agree to move his/her computer to my place for testing purpose.

Note that I suggest opening those ports in Windows Firewall regardless if it's enabled or not, I'm not talking about your router.

Another thing is that the patch server were down from about mid-June hindering people in going online as the game starts with checking the patch server, if there was no reply from the patch server all you got was a message about the game not being able to communicate with the server. Around mid-August people could get online again. Maybe the patch server has been taken down and some script has been put up instead so the game is redirected to GameSpy...

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.

[This message has been edited by PCDania (edited 09-25-2008 @ 07:20 PM).]

You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Legends Heaven | HeavenGames