You must be logged in to post messages.
Please login or register

Tech Support
Moderated by alincarpetman, Aurilux

Hop to:    
Welcome! You are not logged in. Please Login or Register.49 replies
Rise of Legends Heaven » Forums » Tech Support » *URGENT* RoL starts up, but I can't play the game itself - FIXED
Bottom
Topic Subject:*URGENT* RoL starts up, but I can't play the game itself - FIXED
« Previous Page  1 2  Next Page »
GRUNT
Zekeling
posted 06-04-06 05:20 AM EDT (US)         
I don't know what's going on....the game will start up fine, but when I try to view a replay or play a quickmatch, the game just crashes. I see the loading screen for a split second (you know, the big blue screen which shows the minimpa and the players), then it crashes.

And I really do mean split second . It's the same no matter what I try (skirmish, replay, campaign), and I've restarted my computer several times .

I had a lot of problems installing the game in the first place so I really do not want to do it again if I can help it.....does anybody know what can be causing this?


GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
AuthorReplies:
Sir Alock
Zekeling
posted 06-04-06 09:04 AM EDT (US)     1 / 49       
Grunt: 1st off...In a post like yours, it's worthless unless you gives use you "exact" specs of your computer. Also..Let us know what audio & video card diers you're using! Then we might be able to help you!

Common Sense Isn't So Common
Grapeshot
Zekeling
posted 06-04-06 09:09 AM EDT (US)     2 / 49       
There's also a huge thread on crashes. Work your way through it and see how you get on. In the CRASH thread, pay particular attention to the posts by shaggyfellow (name in blue).

[This message has been edited by Grapeshot (edited 06-04-2006 @ 09:11 AM).]

GRUNT
Zekeling
posted 06-04-06 09:12 AM EDT (US)     3 / 49       
Alright thanks, and I also don't know how to check my comp specs ^_^. It's not mine, and I'm kinda computer-inept, or I would have .

GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
Grapeshot
Zekeling
posted 06-04-06 09:20 AM EDT (US)     4 / 49       
I thought your name rang a bell!

So you've had it running fine and this just happened? Strange.

Sounds like a file corruption issue. I had that during my long and painful debugging session. I HAD to reload :: ((

When you loaded it up, did you make sure you had all your anti virus switched off? Also, if you had 'loading from disc' problems, there is a way around it. Create a series of folders called ROL DISK 1 etc and copy each disc to it's corresponding folder. Then install from the PC.

Sir Alock
Zekeling
posted 06-04-06 09:54 AM EDT (US)     5 / 49       
Grunt: In order for you to play certain games, you MUST have a general understanding of your computer system! Knowing what video card you own is the 1st thing you need to get a handle on. Also...Making sure all your drivers are up-to-date. PC Gaming isn't like playing with the XBOX 360. You need to upgrade your box as time goes on or replace it outright.

My computer is over 2 1/2 years old & I have replaced a few things along the way! I hope Ican get another 6-12 months out of her, but @ that point it will be time for a complete new box.


Common Sense Isn't So Common
GRUNT
Zekeling
posted 06-04-06 10:02 AM EDT (US)     6 / 49       
My game's been running fine, though! I've played almost 60 games online, played through the campaign, watch replays all the time.....it's never given me problems until today!

If it does not work tomorrow, I shall have to reinstall it....that'd probably be the best solution .


GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
Grapeshot
Zekeling
posted 06-04-06 10:26 AM EDT (US)     7 / 49       
"PC Gaming isn't like playing with the XBOX 360. "

That's a bit Harsh. Grunt's done some good work on the forum. I don't think he's quite as inexperienced as he makes out. Besides, we're here to play the game, not complete course work in computer engineering (although it has felt like it at times!).I think BHG would be horrified if the community adopted the attiude that ROL is for 'Experts techs only'.

Just reinstall it Grunt. That'll probably fix it. Make sure you defrag after uninstalling and before you reinstall though.

Sir Alock
Zekeling
posted 06-04-06 11:59 AM EDT (US)     8 / 49       
Grapeshot: Please don't be so sensitive! I wasn't being harsh with Grunt, just that "if" you're going to ask for help, then we need the "basic" info. I'm not saying he needs to go & get a computer degree!

BHG would love it if most people had a basic understanding of computers! Most people today simply want to push a button & expect it to work without any issues. I wish it was true myself, but as we know, it is not.


Common Sense Isn't So Common

[This message has been edited by Sir Alock (edited 06-04-2006 @ 12:01 PM).]

Thorney
Zekeling
posted 06-04-06 12:00 PM EDT (US)     9 / 49       
The log might have details about the crash:

.\Documents and Settings\(current user)\Application Data\Microsoft\Rise Of Legends\logs\warning_log.txt

Jumbalaya
Zekeling
posted 06-04-06 12:12 PM EDT (US)     10 / 49       

Quote:

Alright thanks, and I also don't know how to check my comp specs ^_^. It's not mine, and I'm kinda computer-inept, or I would have

to check your specs go to start->run->and then type in 'dxdiag'
From there you should be able to see your sound/video card, processor ect.


lol im jumby
Grapeshot
Zekeling
posted 06-04-06 12:29 PM EDT (US)     11 / 49       
...or hit 'start' > 'all programs'> 'Accessories'> 'system tools'> 'System information'

That'll give you a run down of your complete system.

To get access to your graphic card's details, options and information, just right click on an empty area of your desk top, select 'properties' from the pop-up menu, click on the 'settings' tab, then hit 'advanced' in the right hand corner and you'll have lots of fun stuff to play with. Bit of advice, NEVER force the refresh rate!

Once you know what you've got go to either ATI.com or nvidia.com and update your drivers, if you haven't already done so.

ps

Damn yer eyes, Sir Alock! I'd challenge you to a play off...er, except I'm really bad at ROL ; )

Sir Alock
Zekeling
posted 06-05-06 00:55 AM EDT (US)     12 / 49       
Damn yer eyes, Sir Alock! I'd challenge you to a play off...er, except I'm really bad at ROL ; )

Grapeshot: I'm like you....I'm not a great RTS MP player! I'm kind of old (turned 40 on 12/31/05) So...I still play a lot of turn-based gaming (i.e. Heroes of Might & Magic series, Age of Wonders etc.) More my speed! Or lack of speed.

If you want to play MP w/o any issues, please let me know & I'll e-mail you my address or maybe you have a Gamespy account? Anyway...I live on the East-Coast in the US.

I would love to play MP with a noob like myself who doesn't really care about winning or losing. I simply like having fun playing the game!

Take Care!

Alex


Common Sense Isn't So Common
GRUNT
Zekeling
posted 06-05-06 06:43 AM EDT (US)     13 / 49       
Well, here's my warning log.....I hope it helps....and thanks for the help, guys .

Quote:

Unclassified Warnings
* FileCacheMgr is disabled.: c:\rts2\main\basic\filecachemgr.cpp, 30
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigfileManager--duplicate metrics added to search_index: c:\rts2\main\basic\bigfilemanager.cpp, 306
* BigFile already included: multiplayer_data.big: c:\rts2\main\basic\bigfilemanager.cpp, 87
* BigFile already included: nonloc_strings.big: c:\rts2\main\basic\bigfilemanager.cpp, 87
* BigFile already included: strings.big: c:\rts2\main\basic\bigfilemanager.cpp, 87
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* no big: c:\rts2\main\basic\error.cpp, 38
* File not found: c:\rts2\main\basic\error.cpp, 38
* File not found: c:\rts2\main\basic\error.cpp, 38
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219
* Putting away a file that wasnt touched: c:\rts2\main\basic\FileManifest.cpp, 219

Memory Warnings

UI Warnings

Audio Warnings

MP Warnings
* FirewallDectector::init...CoCreateInstance failed: -2147221164: C:\rts2\Main\game\firewalldetector.cpp, 50

Graphics Warnings

Game Warnings

Loc Warnings

Script Warnings
* ================= Pre-compiled Script Loaded .\data\spells\spells_basic.bhs
* ================= Pre-compiled Script Loaded .\data\spells\allies.bhs
* ================= Pre-compiled Script Loaded .\data\spells\webshot.bhs
* ================= Pre-compiled Script Loaded .\data\spells\get_neutrals.bhs
* ================= Pre-compiled Script Loaded .\data\spells\web.bhs
* ================= Pre-compiled Script Loaded .\data\spells\mind_control.bhs
* ================= Pre-compiled Script Loaded .\data\spells\repair.bhs

Editor Warnings

Physics Warnings

IOReplay Warnings

Here are my specs:

Quote:

Windows XP Professional (5.1, Build 2600)
AMD Athlon XP 2500+, ~1.8GHz
1024 MB RAM
DirectX 9.0c

NVIDIA GeForce 6800 GT

I hope that's all the necessary info :P.


GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t

[This message has been edited by GRUNT (edited 06-05-2006 @ 06:45 AM).]

Grapeshot
Zekeling
posted 06-05-06 08:24 AM EDT (US)     14 / 49       
Sir Alock -

lol! That really made me laugh! I accept, but I'll have to get my multiplayer to connect first though. Yep, it aint working! I'll get back to you in this thread (off topic alert!).

Grunt, that's very strange. I'm not seeing the sort of corruptions I saw, but as the game seems to be searching for files it can't find, the pc may have lost some paths and short cuts. When was the last time you did any defrag, drive checks etc?

Try one of the system tools out there. I use System Mechanic 6
http://www.iolo.com/sm/6/index.cfmThe time limited demo is fully functioning I believe. It'll allow you to identify broken short cuts, optimize memory usage etc.

Biermacht
Zekeling
posted 06-05-06 11:49 AM EDT (US)     15 / 49       
This may be obvious and of no help, but watching a replay of a game played from an older (pre-patched) version of RoL will almost always cause the game to crash.
Thorney
Zekeling
posted 06-05-06 12:10 PM EDT (US)     16 / 49       
The Unclassified Warnings quoted are "normal" those same lines are output for every game session.

MP Warnings
* FirewallDectector::init...CoCreateInstance failed: -2147221164: C:\rts2\Main\game\firewalldetector.cpp, 50

I guess is similar to:

* FirewallDectector::init...get_CurrentProfile failed: -2147023143: C:\rts2\Main\game\firewalldetector.cpp, 64

Another "normal" non-fatal error. I don't see anything unusual in the log. Its crashing before it can write out any errors.

First, check that other DX9 games are functioning okay to eliminate possibility of any system/DirectX/hardware corruption.

Otherwise I'd make careful note of gamespy login, backup replays, campaign saves etc. and reinstall.

Good luck!

GRUNT
Zekeling
posted 06-05-06 06:36 PM EDT (US)     17 / 49       
Other games run fine . Guess I'll have to reinstall...

GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
SonuvBob
Zekeling
posted 06-05-06 07:53 PM EDT (US)     18 / 49       
warning_log.txt is only written out when a game ends successfully, or maybe when you close RoL. Either way, it doesn't help when the game crashes . If the game crashes, check log.html (in the same location); it should contain any error messages from the last game played.
GRUNT
Zekeling
posted 06-06-06 09:44 AM EDT (US)     19 / 49       
Damn, I can't even reinstall it! First of all, I reckon something wasn't right with the installation to begin with, because I can't find an 'uninstall' icon.

When I autorun, the uninstall option is greyed out, but the 'install' option isnt.

Ok fine, I figure....I go to control panel -> add/remove programs........RoL isn't there.

So, I'm out of ideas, I decide to do it the hard way......select the directory I intalled the game in, and hit 'delete'. But......OOPS

So I decide to re-install the game without deleting the old one....I get some error, so it doesnt work (I couldnt take a screenshot because it crashed), but when I started up the game, it was as though it had just been re-installed. I had to accept the license agreement again, enter my name, change my graphics settings.....I started up a game.....crashed in the loading screen . RoL still hates me.

I'm out of ideas.....how the heck do I get rid of the old version of the game so that I can reinstall it?


GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
GreyPawn
Hero
posted 06-06-06 05:24 PM EDT (US)     20 / 49       
Hey there GRUNT,

When in doubt, start from scratch! Firstly, I'd recommend a cold reboot of your system before attempting to do anything, since you are getting permission errors on trying to delete the RoL directory. After that, you should be able to uninstall Rise of Legends by using the Control Panel. If it doesn't exist in Control Panel, nuke the directory itself and anything in My Documents>My Games> that relates to Rise of Legends.

You'll want to be sure that you also have no trace of either Demo or Beta versions of the old Rise of Legends on your machine before attempting to install the retail version. If you do, make sure to uninstall them and you -must- reboot afterwards. With a clean system, you should be able to install from the retail discs and play the game just fine. Hope this helps!

storm legion
Zekeling
posted 06-06-06 06:22 PM EDT (US)     21 / 49       
i wouldn't reccommend this, it's only if you are really REALLY desperate-

basically, back-up everything you need on your comp that's on the same drive as RoL (if your system files [eg, windows xp] are on the same drive as RoL, don't back them up, you'll need to install it from scratch in order for it to work)

then format the drive with RoL in it, it will wipe out everything no questions asked so it has to get rid of it

though after this it's gonna be an absolute pain trying to get everything back to normal, heck if it was me i'd probebly find another game, formatting is the worst thing imaginable @_@ (if you have system files on another seperate drive than the one wiped, then the comp should run fine, otherwise you'll need to insert your OS cd and install the OS again and update it again)

hope you find some other way grunt, because the above method is a really bad choice, but incase you're now wondering 'why the heck did he post it here if it's such a bad choice?' then it's because it may well be the only choice if you want to get your current RoL working


but it probebly won't come to that


_______________________________
...////////////////////\\\\\\\\\\\\\\\\\\\\...

...|\/\////<_/\==/\====/\==/\_>\\\\/\/|...
.../<Storm]]>Storm-legion<[[Winds>\...
...\__/\\\\<_\/==\/====\/==\/_>////\__/...
...\\\\\\\\\\\\\\\\\\\\////////////////////...
Jumbalaya
Zekeling
posted 06-06-06 07:05 PM EDT (US)     22 / 49       
I was going to suggest this but he told me that he lost his win xp disk

lol im jumby
GRUNT
Zekeling
posted 06-07-06 08:17 AM EDT (US)     23 / 49       
During the demo, I had some visual problem with the terrain.....I couldn't get rid of it. However, once I downloaded the CUotl mod for the demo, the problem mysteriously went away....although every now and then, I'd start the game with the texture error, but it'd correct itself a second or so later.

In the retail version, I have the same issue, but like the demo, it goes away at the start. I heard that something about the mod I downloaded fixed the texture error and I'm scared that removing it will return me to the weird texture land of RoL :P.

The game ran fine until just a couple days ago- are you sure the demo's the problem?

Anyway, I managed to erase the directories I installed RoL in the manual way, so now I'll try to reinstall .


GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
GRUNT
Zekeling
posted 06-07-06 09:28 AM EDT (US)     24 / 49       
Well, I reinstalled it......it still doesn't work . I am so confused! Grrrrr....

Poop, I bet this thing isn't going to get fixed before the forum party . And since I've had the game for weeks (over a month now isnt it?), it's too late to get a refund......ARGH!


GRUNT'S UBER COMICS OF DOOM! READ!
http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=st&fn=4&tn=91&st=recent&f=4,91,0,10]z00t[/url]
RoL Online Nick:
ESO name:[/b][url=http://www.agecommunity.com/stats/EntityStats.aspx?loc=en-US&EntityName=z00t&md=ZS_Supremacy]z00t
GreyPawn
Hero
posted 06-07-06 11:32 AM EDT (US)     25 / 49       
Heya GRUNT,

We're releasing a new RoL Troubleshooting doc today to all the fansites that might be of some help to you in resolving your issue. The key thing before a reinstall is making sure that you've got no trace of RoL on your computer, and then rebooting. You might also consider disabling Hardware Audio in the personal.ini file, as that has been successful for some with similar difficulties. Here's how you'd do that-

1. Open the file found under \My Documents\My Games\Rise of Legends\ called "personal.ini" in a text editor, such as Notepad.
2. Scroll to the very bottom and add the following line "HardwareAudio=0" without the quotation marks.
3. Go to File>Save and then Save that over the old one.
4. Run the game.

If none of these solutions work, run a DirectX Diagnostic by typing "dxdiag" in the Windows run box then click Save All Information at the bottom. Send in the dxdiag.txt file it generates to your desktop to info@bighugegames.com and we'll take it further.

« Previous Page  1 2  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Legends Heaven | HeavenGames